Module 4: Routing
Information Protocol Version 2
|
4.2.1 |
Basic
RIP v2 configuration
Router(config)#router rip
Router(config-router)#version [1|2]
Router(config-router)#network network_address
Router(config-router)#no version
|
4.2.2 |
Compatibility with RIP v1
Router(config)#interface
fastethernet0/[0|1|2]
Router(config-if)#ip rip send version [1][2]
Router(config-if)#ip rip receive version [1][2]
|
4.2.3 |
Discontiguous subnets and classless routing
Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#no auto-summary
|
4.2.4 |
Configuring authentication
Router(config)#key chain
[name]
Router(config-keychain)#key [number]
Router(config-keychain-key)#key-string [string]
Router(config-keychain-key)#interface fastethernet 0/0
Router(config-if)#ip rip authentication key-chain [name]
Router(config-if)#ip rip authentication mode [text | md5]
|
4.3.1 |
RIP v2 show
commands
Router#show ip protocols
Router#show ip rip database
Router#show ip route [address [mask] [longer-prefixes]]
| [protocol [process-id]] | [list access-list-number |
access-list-name]
|
4.3.2 |
Debug commands
Router#debug ip rip
Router#debug ip routing
|
|
Module 5: EIGRP |
5.5.1 |
Configuring EIGRP for IP Networks
Router(config)#router
eigrp autonomous-system-number
Router(config-router)#network network-number
Router(config-if)#bandwidth kilobits
Router(config-router)#eigrp log-neighbor-changes
|
5.5.3 |
The
Bandwidth-Percent Command
Router(config-if)#ip
bandwidth-percent eigrp as-number percent
|
5.5.4 |
Summarizing EIGRP Routes for IP
Router(config-router)#no
auto-summary
|
5.5.5 |
Summarizing EIGRP Routes for IP
Router(config-if)#ip
summary-address eigrp as-number network-address subnet-mask
[admin-distance]
|
5.6.1 |
Verifying
EIGRP Operation
EIGRP Show Commands:
Router#show ip eigrp neighbors [type number][details]
Router#show ip eigrp interfaces [interface-type interface-number][as-number]
Router#show ip eigrp topology [as-number | [[ip-address]
mask]] [active | all-links |
pending | summary | zero-successors]
Router#show ip eigrp traffic [as-number]
EIGRP Debug Commands:
Router#debug eigrp fsm
Router#debug eigrp packet
|
|
Module 6:
OSPF
|
6.3.1 |
Configuring OSPF on routers within a single area
Router(config)#router ospf
process-id
Router(config-router)#network network-address
wild-card-mask area area-id
|
6.3.2 |
Optional
configuration commands
Configuring a Loopback Address:
Router(config)#interface
loopback number
Router(config-if)#ip address ip-address subnet-mask
Modifying OSPF Router Priority
Router(config-if)#ip
ospf priority number
|
6.3.3 |
Optional
configuration commands (con’t)
Router(config-if)#ip ospf cost number
Router(config)#interfaces (number)
Router(config-if)#bandwidth (number)
Configuring Authentication:
Router(config-if)#ip
ospf authentication-key password
Router(config-router)#area number authentication [message-digest]
Configuring OSPF Timers:
Router(config-if)#ip
ospf message-digest-key key-id md5 [encryption-type]
password
Router(config-if)#ip ospf hello-interval seconds
Router(config-if)#ip ospf dead-interval seconds
|
6.3.5 |
Clear and
Debug Commands
Router#clear ip route {network [mask] | *}
Router#debug ip ospf adj
Router#debug ip ospf events
Router#debug ip ospf flood
Router#debug ip ospf lsa-generation
Router#debug ip ospf packet
Router#debug ip ospf retransmission
Router#debug ip ospf spf
Router#debug ip ospf tree
|
6.4.4 |
Point-to-Multipoint OSPF
Router(config-if)#ip ospf network point-to-multipoint
Router(config-if)#frame-relay map ip address dlci
broadcast
|
6.6.2 |
Configuring OSPF route summarization
Router(config-router)#area area-id range
address mask
Router(config-router)#summary-address address mask
|
6.6.3 |
Verifying
multiarea OSPF operation
Router#show ip ospf border-routers
Router#show ip ospf virtual-links
Router#show ip ospf process-id
Router#show ip ospf database
|
6.7.3 |
Configuring stub and totally stubby areas
Router(config-router)#area area-id stub
[no-summary]
Router(config-router)#area area-id default-cost
cost
|
6.7.8 |
Configuring NSSA
Router(config-router)#area area-id nssa [no-summary]
Router(config-router)#summary-address prefix mask [not-advertise]
[tag tag]
|
6.8.2 |
Configuring virtual links
Router(config-router)#area area-id virtual-link
router-id
|
|
Module 7: IS-IS |
7.5.1 |
Basic
configuration of Integrated IS-IS
Router(config)#router
isis [area tag]
Router(config)#net [network-entity-title]
Router(config-if)#router isis [area tag]
Router(config-router)#net [network-entity-title]
|
7.5.2 |
Multiarea
Integrated IS-IS Configuration
Router(config-router)#is-type
{level-1 | level-1-2 | level-2-only}
Router(config)#show clns neighbor
Router(config)#show clns traffic
Router(config)#show clns interface-type interface-number
Router(config)#show isis database [detail]
Router(config)#show ip route isis
Router(config)#show isis spf-log
Router(config)#isis password password [level-1 |
level-2]
Router(config)#summary-address address mask {level-1 |
level-1-2 | level-2} prefix mask
Router(config-if)#isis circuit-type {level-1 | level-1-2 |
level-2-only}
Router(config-if)#isis metric default-metric {level-1 |
level-2}
Router(config-if)#debug isis spf-triggers
|
7.6.3 |
Frame
Relay point-to-point scenario with Integrated IS-IS
Router(config)#frame-relay
interface-dlci
Router(config)#show frame-relay
map
Router(config)#debug isis adj-packet
|
|
Module 8: Route
Optimization
|
8.1.2 |
Passive
Interfaces
Router(config)#router rip
Router(config-router)#network network number
Router(config-router)#passive-interface type number
|
8.1.3 |
Filtering
Routing Updates with Distribute-List
Router(config-router)#distribute-list access-list-number
in [interface-name]
Router(config-router)#distribute-list access-list-number
out [interface-name | routing-process |
as-number]
RTZ(config-router)#distribute-list access-list-number
out
Configuring a Passive EIGRP
Interface Using distribute-list Command
RTA(config)#router eigrp access-list-number
RTA(config-router)#network network number
RTA(config-router)#distribute-list access-list-number
out interface interface-name
RTA(config-router)#exit
RTA(config)#access-list access-list-number deny
any
|
8.3.4 |
Modifying
Administrative Distance by Using the Distance Command
Router(config-router)#distance weight {source-ip-address
source-mask [access-list-number | name]}
|
8.3.6 |
Configuring one-way redistribution
Router(config-router)#redistribute protocol [process-id]
{level-1 | level-1-2 | level-2} [metric
metric-value][metric-type type-value] [match
{internal | external 1 | external 2}][tag
tag-value] [route-map map-tag][weight
weight] [subnets]
|
|
Module 9: BGP
|
9.3.1 |
Basic BGP
configuration
Router(config-router)#network
network-number [mask network-mask]
Router(config-router)#neighbor ip-address remote-as
AS-number
|
9.3.4 |
EBGP multihop
Router(config-router)#neighbor
ip-address ebgp-multihop [hops]
|
9.3.5 |
Clearing
the BGP table
Router#clear ip bgp {* | address
| peer-group name} [soft [in | out]]
Router#clear ip bgp route network-address
|
9.4.1 |
Verifying
BGP operation
Router#show ip bgp
Router#show ip bgp summary
Router#show ip bgp neighbors
Router#show ip bgp paths
|
9.5.3 |
Implementing BGP routing policy
Router(config)#route-map
map-tag [permit | deny] [sequence-number]
|
9.6.4 |
Next Hop
behavior on NBMA networks
Router(config-router)#neighbor
IP-address next-hop-self
|
9.6.6 |
AS_Path
and private AS numbers
Router(config-router)#neighbor
IP-address remove-private-as
|
9.6.7 |
The Atomic
Aggregate attribute
Router(config-router)#aggregate-address
address mask [as-set] [summary-only] [suppress-map
map-name][advertise-map map-name] [attribute-map
map-name]
|
9.6.10 |
Manipulating Local Preference
Router(config-router)#bgp
default local-preference value
Router(config)#ip as-path access-list access-list-number
{permit | deny} as-regular-expression
|
9.6.11
|
The Weight
attribute
Router(config-router)#neighbor
IP-address weight number
|
9.6.12
|
The
Multiple Exit Discriminator attribute
Router(config-router)#bgp
always-compare-med
|
9.8.4 |
The ip
prefix-list command
Router(config)#ip
prefix-list list-name [seq seq-value] {deny
| permit network/length} [ge ge-value] [le
le-value]
|
9.9.3 |
Load
balancing
Router(config-router)#neighbor
IP-address default-originate
|
9.9.5 |
Load
balancing
Router(config-router)#maximum-paths
number
|
|
Case Study 1: EIGRP |
There are no commands in this module. |
|
Case Study 2: OSPF |
There are no commands in this module. |
|
Case Study 3: BGP/OSPF
Routing |
There are no commands in this module. |
|
|